Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2877 closed defect (duplicate)

Cannot specify another database in Meta.db_table

Reported by: mikhail@… Owned by: adrian
Component: Database layer (models, ORM) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I cannot specify a table in another database using "class Meta: db_table = 'other_db.table'", what I can do if I directly work with MySQL.

Change History (2)

comment:1 Changed 9 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from new to closed

Check out the multi-db branch of Django, which supports connecting to as many different databases as you like:

Documentation is at the MultipleDatabaseSupport wiki page.

Dupe of #1142.

comment:2 Changed 9 years ago by anonymous

Why I should use several connections? In MySQL, I can use several internal databases within one connection.

Note: See TracTickets for help on using tickets.
Back to Top