Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#28753 closed Cleanup/optimization (worksforme)

Unit tests documentation does not specify non-python requirements

Reported by: Daniel Patrick Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Could not see the requirement (libmemcached-dev on my system) mentioned anywhere (although I most definitely could have missed it) but I think it would have helped me a little if it was mentioned in https://docs.djangoproject.com/en/dev/internals/contributing/writing-code/unit-tests/#running-the-unit-tests

Change History (3)

comment:1 Changed 13 months ago by Will Johnson

I ran in to this same error when installing the requirements on a fresh system. However, the paragraphs below the "Quickstart" commands tell you that to run all the tests, you will need the requirements installed. One of these being "memcached, plus a supported Python binding".

comment:2 Changed 13 months ago by Tim Graham

Resolution: worksforme
Status: newclosed
Type: UncategorizedCleanup/optimization

This idea has been raised before and we addressed it with this addition:

Installing the requirements will likely require some operating system packages that your computer doesn’t have installed. You can usually figure out which package to install by doing a Web search for the last line or so of the error message. Try adding your operating system to the search query if needed.

I'd rather use that approach and/or have developers consult the documentation for each Python package rather than redocument the requirements in Django's docs.

comment:3 Changed 13 months ago by Daniel Patrick

Noted - I should've read more clearly. I guess the fact that the comment regarding requirements comes after rather than before the instructions for installation and running seems a bit odd, though. Thanks.

Note: See TracTickets for help on using tickets.
Back to Top