Opened 7 months ago

Closed 7 months ago

#28698 closed Cleanup/optimization (duplicate)

Show template origin in TemplateSyntaxError

Reported by: Jonas Haag Owned by: nobody
Component: Template system Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

Example of current error message:

django.template.exceptions.TemplateSyntaxError: Invalid block tag on line 8: 'trans', expected 'endblock'. Did you forget to register or load this tag?

With my patch:

django.template.exceptions.TemplateSyntaxError: app/yourtemplate.html: Invalid block tag on line 8: 'trans', expected 'endblock'. Did you forget to register or load this tag?

I'm willing to contribute tests and documentation if the general idea is accepted.

Change History (2)

comment:2 Changed 7 months ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #28050.

Note: See TracTickets for help on using tickets.
Back to Top