Opened 8 years ago

Closed 8 years ago

#2865 closed defect (fixed)

Refernce to request.META.SERVER_PORT cause httpd crush on Apache 2.2.2/mod_python 3.2.8

Reported by: ymasuda <ymasuda@…> Owned by: adrian
Component: Core (Other) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Starting from #3866, reference to request.META.SERVER_PORT is causing httpd crush on Apache 2.2.2/mod_python 3.2.8/Python 2.4.3/MacOSX 10.4.7.
Here is the relevant error_log:

[Tue Oct 03 12:35:05 2006] [notice] child pid 2649 exit signal Trace/BPT trap (5
)
dyld: lazy symbol binding failed: Symbol not found: _apr_sockaddr_port_get
  Referenced from: /usr/local/apache2/modules/mod_python.so
  Expected in: flat namespace

dyld: Symbol not found: _apr_sockaddr_port_get
  Referenced from: /usr/local/apache2/modules/mod_python.so
  Expected in: flat namespace

This seems to be caused by referencing connection.local_addr attribute of a request object.
Since I could not find any alternatives to find correct SERVER_PORT, I suggest just revert #3866.

Change History (2)

comment:1 Changed 8 years ago by Yasushi Masuda <ymasuda@…>

  • Component changed from Admin interface to Core framework

comment:2 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [3927]) Fixed #2865 -- Reverted [3866] (problem with mod_python SERVER_PORT

Note: See TracTickets for help on using tickets.
Back to Top