#28611 closed Cleanup/optimization (duplicate)

Redirects contrib app - CharField(max_length=200) is too little

Reported by: Artur Barseghyan Owned by: nobody
Component: contrib.redirects Version: 1.11
Severity: Normal Keywords: redirects
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Nowadays, paths are long. It would make sense either:

(Option 1): Change the old_path and new_path from CharField to TextField.
(Option 2): Let the RedirectFallbackMiddleware middleware use customized Redirect model.

If any of the solutions is found acceptable, I could come up with a pull request.

Best regards,

Change History (1)

comment:1 Changed 22 months ago by Tim Graham

Resolution: duplicate
Status: newclosed
Type: UncategorizedCleanup/optimization

Duplicate of #19515.

Note: See TracTickets for help on using tickets.
Back to Top