Code

Opened 8 years ago

Closed 6 years ago

#2839 closed defect (worksforme)

Filter translation ignores "By"

Reported by: patrick@… Owned by: nobody
Component: contrib.admin Version: master
Severity: normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

in the admin-interface, the word "By" is not translated in the filters.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by ramiro

Are you talking about just the German translation or are you saying the there are literals missing the necessary _() to appear as a translatable literals? (in the last case this affects all translations, but I can't find such unstranslated literals occurrence in the admin app, could you point to the exact page/place?).

Also, are you using a recent SVN checkout of the Django trunk or some specific revision?.

comment:2 Changed 7 years ago by adrian

patrickk leaves this comment:

in filterspecs, line 40

t.append(_('<h3>By %s:</h3>\n<ul>\n') % self.title())

in filter.html, line 2

<h3>{% blocktrans with title|escape as filter_title %} By
{{ filter_title }} {% endblocktrans %}</h3>

in django.po, line 354:

"<h3>By %s:</h3>\n
"<ul>\n"
msgstr ""
"<h3>Nach %s:</h3>\n"
"<ul>\n"

in my view, that somehow doesn´t fit together.
in filter.html, the translated title doesn´t include "<h3>" - the
translation-file looks for <h3> though.

i´m using the latest SVN.

comment:3 Changed 7 years ago by Simon G. <dev@…>

  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 6 years ago by kratorius

  • Resolution set to worksforme
  • Status changed from new to closed

I haven't been able to reproduce the problem. Since this a 2 years old bug probably has been fixed at some point in the past, so closing as worksforme.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.