Opened 2 years ago

Closed 2 years ago

#28235 closed Bug (invalid)

LiveServerTestCase crashes because it got a ParseResultBytes instance

Reported by: Curtis Maloney Owned by: nobody
Component: Testing framework Version: 1.11
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I'm not sure why urllib.parse.urlparse is returning a Bytes result in this case, but the result is the following error:

Traceback (most recent call last):
  File "/opt/python/3.3.5/lib/python3.3/wsgiref/handlers.py", line 137, in run
    self.result = application(self.environ, self.start_response)
  File "/home/travis/virtualenv/python3.3.5/lib/python3.3/site-packages/django/test/testcases.py", line 1106, in __call__
    if not self._should_handle(get_path_info(environ)):
  File "/home/travis/virtualenv/python3.3.5/lib/python3.3/site-packages/django/test/testcases.py", line 1077, in _should_handle
    return path.startswith(self.base_url[2]) and not self.base_url[1]
TypeError: startswith first arg must be str or a tuple of str, not bytes

It's caused by a simple test case:

class RPCClientTest(LiveServerTestCase):

    def setUp(self):
        self.rpc = client.RPCClient(self.live_server_url + '/rpc/')

    def test_echo(self):
        resp = self.rpc.echo(foo='bar')
        self.assertEqual(resp, {'foo': 'bar'})

Where RPCClient uses a requests Session to post to the url.

I've kludged the following patch to make it work:

diff -urw django/test/testcases.py /home/curtis/src/git/django-nap/venv/lib/python3.5/site-packages/django/test/testcases.py
--- django/test/testcases.py	2017-05-24 12:08:14.870948448 +1000
+++ /home/curtis/src/git/django-nap/venv/lib/python3.5/site-packages/django/test/testcases.py	2017-05-24 11:07:53.967738745 +1000
@@ -41,6 +41,11 @@
 from django.utils.six.moves.urllib.parse import (
     unquote, urljoin, urlparse, urlsplit, urlunsplit,
 )
+try:
+    from urllib.parse import ParseResultBytes
+except ImportError:
+    class ParseResultBytes:
+        pass
 from django.utils.six.moves.urllib.request import url2pathname
 from django.views.static import serve
 
@@ -1183,6 +1188,8 @@
     def __init__(self, application):
         self.application = application
         self.base_url = urlparse(self.get_base_url())
+        if isinstance(self.base_url, ParseResultBytes):
+            self.base_url = self.base_url.decode('utf-8')
         super(FSFilesHandler, self).__init__()
 
     def _should_handle(self, path):

Change History (4)

comment:1 Changed 2 years ago by Curtis Maloney

As can be seen here the error happens on 1.8 to 1.11.2, and py 3.3 - 3.6

https://travis-ci.org/funkybob/django-nap/builds/235472369

comment:2 Changed 2 years ago by Curtis Maloney

Setting STATIC_URL in settings fixed this issue.

comment:3 Changed 2 years ago by Tim Graham

Do you plan to investigate further as to whether your patch is a good approach?

comment:4 Changed 2 years ago by Tim Graham

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top