Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#28130 closed Bug (fixed)

Formset validate_min validation ignores unchanged forms

Reported by: Jim Ouwerkerk Owned by: nobody
Component: Forms Version: 1.11
Severity: Release blocker Keywords: formsets
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Tim Graham)

The formset validation is changed because of ticket #26844.

However, the fix for the empty forms breaks the validate_min validation for formset with existing unchanged form data in Django 1.11.
It counts unchanged existing forms as 'empty' form because they are not changed, but they should not be counted as empty.

Change History (5)

comment:1 Changed 2 years ago by Tim Graham

Description: modified (diff)
Severity: NormalRelease blocker
Summary: Formset validate_min validation does not work on existing formsFormset validate_min validation ignores unchanged forms
Triage Stage: UnreviewedAccepted

comment:2 Changed 2 years ago by Tim Graham

Has patch: set

comment:3 Changed 2 years ago by Claude Paroz

Triage Stage: AcceptedReady for checkin

comment:4 Changed 2 years ago by GitHub <noreply@…>

Resolution: fixed
Status: newclosed

In f04a4049:

Fixed #28130 -- Fixed formset min_num validation with initial, unchanged forms.

Regression in f5c6295797b8332134fd89e0209a18a1d1d45e0c.

comment:5 Changed 2 years ago by Tim Graham <timograham@…>

In e93135b0:

[1.11.x] Fixed #28130 -- Fixed formset min_num validation with initial, unchanged forms.

Regression in f5c6295797b8332134fd89e0209a18a1d1d45e0c.

Backport of f04a40491764bdc9a2ebbfc03fa7be424fb3ce63 from master

Note: See TracTickets for help on using tickets.
Back to Top