Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#28097 closed Bug (fixed)

Incorrect layout of ReadOnlyPasswordHashWidget widget in user admin

Reported by: Claude Paroz Owned by: Tim Graham
Component: contrib.auth Version: 1.11
Severity: Release blocker Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

With the new template-based widget rendering, the admin password widget display is a bit awkward. See attached screenshot. Also, I'm not sure if the the nesting of divs is wanted.

Attachments (1)

admin_password_widget.png (12.8 KB) - added by Claude Paroz 2 years ago.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by Claude Paroz

Attachment: admin_password_widget.png added

comment:1 Changed 2 years ago by Aymeric Augustin

This looks like a regression to me.

comment:2 Changed 2 years ago by Tim Graham

Component: contrib.admincontrib.auth
Owner: changed from nobody to Tim Graham
Status: newassigned
Summary: Strange layout of password widget in user adminIncorrect layout of ReadOnlyPasswordHashWidget widget in user admin
Triage Stage: UnreviewedAccepted

comment:3 Changed 2 years ago by Tim Graham

Has patch: set

comment:4 Changed 2 years ago by Claude Paroz

Triage Stage: AcceptedReady for checkin

Thanks for the fix!

comment:5 Changed 2 years ago by GitHub <noreply@…>

Resolution: fixed
Status: assignedclosed

In dff559f:

Fixed #28097 -- Fixed layout of ReadOnlyPasswordHashWidget.

comment:6 Changed 2 years ago by Tim Graham <timograham@…>

In cf1e682:

[1.11.x] Fixed #28097 -- Fixed layout of ReadOnlyPasswordHashWidget.

Backport of dff559ff83a6aac14de0bbca58101786edf4195f from master

Note: See TracTickets for help on using tickets.
Back to Top