Opened 5 years ago

Closed 5 years ago

#28063 closed New feature (duplicate)

Allow to use add() with ManyToManyField which specifies an intermediary model

Reported by: Victor Porton Owned by: nobody
Component: Database layer (models, ORM) Version: 1.11
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

AttributeError: Cannot use add() on a ManyToManyField which specifies an intermediary model. Use post_app.PostInTimeline's Manager instead.

Please make it possible if the intermediary model has only fields with a default value (or null), except of the (two) foreign keys of two linked models.

Change History (1)

comment:1 Changed 5 years ago by Simon Charette

Resolution: duplicate
Status: newclosed

Duplicate of #9475.

Note: See TracTickets for help on using tickets.
Back to Top