Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#27932 closed Cleanup/optimization (duplicate)

EmailValidator fails on "a.@example.com"

Reported by: Aur Saraf Owned by: MisRob
Component: Core (Mail) Version: 1.10
Severity: Normal Keywords:
Cc: robosova.michaela@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

This is a perfectly valid email address, and I found it because a user of mine tried to register with a similar address.

I confirmed that I can send email to aur.@feezback.com.

Change History (6)

comment:1 Changed 13 months ago by MisRob

Owner: changed from nobody to MisRob
Status: newassigned

comment:2 Changed 13 months ago by MisRob

Resolution: invalid
Status: assignedclosed

I would say it is perfectly fine that this e-mail didn't pass through e-mail validation because dot character is not allowed as the last character of the email local-part.
Pls. see https://tools.ietf.org/html/rfc5322, sections 3.4.1, 3.2.3, 3.2.4 and 4.4.
Maybe some mail servers still allow this obsolete syntax but this fact surely doesn't mean EmailValidator should accept it.

comment:3 Changed 13 months ago by MisRob

Cc: robosova.michaela@… added
Component: UncategorizedCore (Mail)

comment:4 Changed 13 months ago by Tim Graham

By the way, #26423 will change EmailValidator to use HTML5 validation. That validation is more liberal and may accept this address.

comment:5 Changed 13 months ago by MisRob

Resolution: invalidduplicate

Oh, that's a good point! I had no idea about this, sorry. It seems to be a nice idea to simplify the validation. Anyone can use custom regex if needed. So I guess it will be better to close this one as duplicate to #26423.

comment:6 Changed 13 months ago by MisRob

Type: UncategorizedCleanup/optimization
Note: See TracTickets for help on using tickets.
Back to Top