Code

Opened 8 years ago

Closed 8 years ago

#2754 closed defect (worksforme)

Admin panel broken: module object has no attribute urlpatterns

Reported by: Jarosław Zabiełło Owned by: adrian
Component: contrib.admin Version: master
Severity: blocker Keywords: panel linux urlpatterns
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

System: Debian 3.1, Python 2.4.3, Django SVN (rev.3768)

Request Method:  	GET
Request URL: 	http://biblia.apologetyka.com/admin/
Exception Type: 	AttributeError
Exception Value: 	'module' object has no attribute 'urlpatterns'
Exception Location: 	/usr/local/lib/python2.4/site-packages/Django-0.95-py2.4.egg/django/core/urlresolvers.py in resolve, line 156

This problem exists only under Linux. Under WindowsXP everything works fine. I thought that mayby fasctgi was broken, but it was not the case because this exception raises even when I lauch my Django project with: manage.py runserver. I left my url when you can see detailed info: http://biblia.apologetyka.com/admin/

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by ubernostrum

  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to reproduce this (admin works fine for me on both Linux and Mac OS X), and if it were truly a problem in Django we'd be getting tons of reports of it, so it's got to be a configuration issue on your server.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.