Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#27479 closed Cleanup/optimization (fixed)

ingored GDALException('Invalid pointer returned from "GDALClose"',) during tests

Reported by: Sergey Fedoseev Owned by: Sergey Fedoseev
Component: GIS Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I have many Exception django.contrib.gis.gdal.error.GDALException: GDALException('Invalid pointer returned from "GDALClose"',) in ignored messages when running tests. Installed version of GDAL is 2.1.2.

Change History (7)

comment:1 Changed 3 years ago by Sergey Fedoseev

Owner: changed from nobody to Sergey Fedoseev
Status: newassigned

comment:2 Changed 3 years ago by Sergey Fedoseev

Has patch: set

comment:3 Changed 3 years ago by Claude Paroz

Patch needs improvement: set
Triage Stage: UnreviewedAccepted

I can reproduce the issue, but if I simply apply your patch, I'm getting a bunch of other errors:
Exception django.contrib.gis.gdal.error.GDALException: GDALException('AppDefined',) in <bound method GDALRaster.__del__ of <Raster object at 0x7f2f712fd250>> ignored.

comment:4 in reply to:  3 Changed 3 years ago by Sergey Fedoseev

Replying to Claude Paroz:

I can reproduce the issue, but if I simply apply your patch, I'm getting a bunch of other errors:
Exception django.contrib.gis.gdal.error.GDALException: GDALException('AppDefined',) in <bound method GDALRaster.__del__ of <Raster object at 0x7f2f712fd250>> ignored.

Can't reproduce it. Maybe you didn't copy errcheck=False :-).

Last edited 3 years ago by Sergey Fedoseev (previous) (diff)

comment:5 Changed 3 years ago by Claude Paroz

Patch needs improvement: unset
Triage Stage: AcceptedReady for checkin

/me hides.

comment:6 Changed 3 years ago by Claude Paroz <claude@…>

Resolution: fixed
Status: assignedclosed

In faf8a25:

Fixed #27479 -- Fixed GDALClose prototype. (#7546)

comment:7 Changed 3 years ago by Claude Paroz <claude@…>

In eff483f:

[1.10.x] Fixed #27479 -- Fixed GDALClose prototype

Backport of faf8a253d3fc2d870fb7ab860581e942d2ad9fbc from master.

Note: See TracTickets for help on using tickets.
Back to Top