Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2739 closed task (invalid)

There is no build-in support for data related to a anonymous user

Reported by: anonymous Owned by: adrian
Component: Contrib apps Version:
Severity: major Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

it makes the code really ugly having to deal with relating data to a anon user manually
also it screws stuff if more then one app needs data related to anon users

being nullable is a possible solution,
but i think its a bad solution,
since it breaks stuff like assigning permissions to the anon user by database entries
and makes select_related less effective

Change History (2)

comment:1 Changed 9 years ago by mtredinnick

Can you please clarify what the problem is here. It sounds like you are trying to keep track of different anonymous users, but then there would be no way to tell them apart.

comment:2 Changed 9 years ago by adrian

  • Resolution set to invalid
  • Status changed from new to closed

Marking as invalid.

Note: See TracTickets for help on using tickets.
Back to Top