Opened 9 years ago

Closed 8 years ago

#2717 closed defect (duplicate)

edit_inline interaction with auto_now_add on update raising an exception

Reported by: antoni.aloy@… Owned by: adrian
Component: contrib.admin Version: master
Severity: blocker Keywords: edit_inline
Cc: gary.wilson@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Add a warning in the documentation about edit_inline, as is not working as espected:

  • If you have a DateField with auto_now_add, if you try to make an update it tries to put that field to NULL, giving an exception.
  • If you modify the parend record and the child one you'll get an exception.
  • Sometimes you're not able to insert any child record, but there is no error message.

It works fine for simple cases, but it crashes if you try to do some real work.

Change History (6)

comment:1 Changed 9 years ago by ubernostrum

Most of these, I think, are known bugs. I'll go through and find them when I have a free minute, then close this as a duplicate.

comment:2 Changed 9 years ago by Gary Wilson <gary.wilson@…>

  • Cc gary.wilson@… added
  • milestone changed from Version 0.93 to Version 1.0

milestone 0.93 has passed.

comment:3 Changed 8 years ago by ubernostrum

The auto_now_add bug is a duplicate of #1030.

comment:4 Changed 8 years ago by anonymous

  • milestone Version 1.0 deleted

Milestone Version 1.0 deleted

comment:5 Changed 8 years ago by Simon G. <dev@…>

  • Summary changed from edit_inline does not work to edit_inline interaction with auto_now_add on update raising an exception

comment:6 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

dup of #1030.

Note: See TracTickets for help on using tickets.
Back to Top