Opened 7 years ago

Closed 7 years ago

#26994 closed Cleanup/optimization (duplicate)

Remove blank line after template have been rendered

Reported by: william1835 Owned by: william1835
Component: Template system Version: dev
Severity: Normal Keywords: template
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I have noticed that after a template in Django has been rendered, the lines where the template tags and filters have been used still remain. I know that this does not affect the outcome of the webpage as such, but it is of slight annoyance, and could potentially increase page loading times.

Example (not realistic):
This:

{% load customFilters %}
<!DOCTYPE html>
<html>
</html>

is rendered as:

       
<!DOCTYPE html>
<html>
</html>

This can become noticeable in big files, especially when for loops are used.
Thanks in advance

Change History (2)

comment:1 Changed 7 years ago by william1835

Owner: changed from nobody to william1835
Status: newassigned

comment:2 Changed 7 years ago by Tim Graham

Resolution: duplicate
Status: assignedclosed

Duplicate of #2594

Note: See TracTickets for help on using tickets.
Back to Top