Opened 3 years ago

Closed 3 years ago

#26809 closed Uncategorized (worksforme)

problem with pdf tutorial 1.9.8.dev20160618150023 polls/templates/polls/index.html

Reported by: Chad Brabec Owned by: nobody
Component: Documentation Version: 1.9
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

i just went through your tutorial and when trying to look at the polls that i have made, i keep getting a --
Page not found (404)
Request Method: GET
Request URL: http://192.168.122.22:9000/polls/2//

what i have found is that this code --

page 33 at bottom in polls/templates/polls/index.html

{% for question in latest_question_list %}
<li><a href="/polls/{{ question.id }}/">{{ question.question_text }}</a></li>
{% endfor %}

seems to be entering an additional forward slash '/' to the url at the end of the request.

if i delete the forward slash after the first set of curly braces then the browser will go to the requested question that i'm looking for.

{% for question in latest_question_list %}
<li><a href="/polls/{{ question.id }}">{{ question.question_text }}</a></li>
{% endfor %}

i thought that i could get rid of the forward slash in polls/urls.py after the <pk>[0-9] and right before the $ yet that didn't matter. removing that forward slash in polls/index.html seemed to be the only fix that i could find.

i have tried this with firefox 46.0.1 and chromium 51.02704 both on debian 8.5
django 1.9.7, Python 3.5.2rc1 on virtual host running debian 9(testing)

just thought you might want to know for other newbies like me.

take care

Change History (1)

comment:1 Changed 3 years ago by Tim Graham

Resolution: worksforme
Status: newclosed

Not sure what the issue might be, but the tutorial looks correct. If you want to debug further, please see TicketClosingReasons/UseSupportChannels and provide your entire project.

Note: See TracTickets for help on using tickets.
Back to Top