Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#26153 closed Bug (fixed)

Allow get_extra_descriptor_filter to return Q-objects

Reported by: Anssi Kääriäinen Owned by: nobody
Component: Database layer (models, ORM) Version: 1.9
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In django 1.8 it was possible to return Q-objects from ForeignObject.get_extra_descriptor_filter(). In Django 1.9 the return value must be a dictionary.

The problem is that in Django 1.9 it is impossible to return an OR combined condition. While the get_extra_descriptor_filter() is private API I'd like to maintain the ability to return Q-objects. This is straightforward patch with little regression risks.

Change History (4)

comment:1 Changed 3 years ago by Tim Graham

Patch needs improvement: set
Triage Stage: UnreviewedAccepted

comment:2 Changed 3 years ago by Anssi Kääriäinen

Patch needs improvement: unset

comment:3 Changed 3 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: newclosed

In 353aecbf:

Fixed #26153 -- Reallowed Q-objects in ForeignObject.get_extra_descriptor_filter().

comment:4 Changed 3 years ago by Tim Graham <timograham@…>

In 25496f0f:

[1.9.x] Fixed #26153 -- Reallowed Q-objects in ForeignObject.get_extra_descriptor_filter().

Backport of 353aecbf8c1a8cc6f3985149e2895d49e53dfc1c from master

Note: See TracTickets for help on using tickets.
Back to Top