Opened 4 years ago

Closed 4 years ago

#26130 closed Cleanup/optimization (duplicate)

Convert ModelAdmin views to class-based views

Reported by: Yoong Kang Lim Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

ModelAdmin's views, especially changeform_view(), changelist_view() are long methods that are a bit hard to follow. They would benefit from some refactoring.

I propose converting some of them to CBVs to make them easier to read.

Change History (1)

comment:1 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed
Summary: ModelAdmin views are too messyConvert ModelAdmin views to class-based views

Duplicate of #17208

Note: See TracTickets for help on using tickets.
Back to Top