Opened 3 years ago

Closed 3 years ago

#26065 closed Uncategorized (invalid)

psycopg2 __init__ reports an error: DLL load failed: The specified module could not be found

Reported by: Albert Vigil Owned by:
Component: contrib.postgres Version: 1.9
Severity: Normal Keywords: psycopg2, Windows 10, __init___, postgres
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Shai Berger)

I am unable to use PostGresql with Django on my Windows 10 installation. The error is traced back to __init__.py of psycopg2, line 50: psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID.

I suspect this is some kind of DLL incompatibility. I am using PostGres 9.2, Python 3.5.1, and Django 1.9 on a Windows 10 PC. Have tried to install psycgp2 from pip and the exe file with the same result.

Does any one out there know of a combination of these three programs that works? This issue has been reported on and off for years, but none of the solutions that I have run across do not work for me.

Change History (1)

comment:1 Changed 3 years ago by Shai Berger

Description: modified (diff)
Resolution: invalid
Status: newclosed

I sympathize with your hardships, and yet I see no problem with Django reported here. There might be one if you were able to use psycopg2 from Python outside Django, and only had a problem with Django, but I see nothing like that in the report.

If you can show there actually is some problem with Django, feel free to reopen. Otherwise, the Django issue tracker is not the place to ask for help.

You can try the django-users mailing list, or some psycopg2 forums.

Note: See TracTickets for help on using tickets.
Back to Top