Opened 6 years ago

Closed 6 years ago

#26047 closed Bug (duplicate)

ProcessFormView does not pass **kwargs to get_context_data()

Reported by: Dmitrij Strelnikov Owned by: nobody
Component: Generic views Version: 1.9
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Why the ProcessFormView's functions does not accept kwargs passed via urls for i.e.?

get returns only self.get_context_data which is not updated with passed args and kwargs

def get(self, request, *args, **kwargs):
        """
        Handles GET requests and instantiates a blank version of the form.
        """
        form = self.get_form()
        return self.render_to_response(self.get_context_data(form=form))

Change History (2)

comment:1 Changed 6 years ago by Tim Graham

Are you suggesting following the behavior that TemplateView has of pushing kwargs into the context as described in #19878 (which that ticket suggests we should stop doing)?

comment:2 Changed 6 years ago by Tim Graham

Resolution: duplicate
Status: newclosed
Summary: ProcessFormView des not accept **kwargs from urlsProcessFormView does not pass **kwargs to get_context_data()

I think this is a duplicate of #21964 (marked wontfix). If not, please reopen with a clarification of what you are suggesting the code be changed to.

Note: See TracTickets for help on using tickets.
Back to Top