#25895 closed Cleanup/optimization (fixed)
Customizing user admin docs shouldn't override name.
Description ¶
https://github.com/django/django/blob/master/docs/topics/auth/customizing.txt#L342
In the above documentation, we're inheriting from UserAdmin
while renaming our own class UserAdmin
. Instead, we should rename one of the two of those so it is more clear (and generally doesn't throw pylint errors).
Change History (8)
comment:1 by , 9 years ago
Triage Stage: | Unreviewed → Accepted |
---|---|
Type: | Uncategorized → Cleanup/optimization |
Version: | 1.9 → master |
by , 9 years ago
Attachment: | 25895.diff added |
---|
comment:2 by , 9 years ago
Has patch: | set |
---|
comment:4 by , 9 years ago
Triage Stage: | Accepted → Ready for checkin |
---|
In release notes, you can let one of MyUserAdmin / BaseUserAdmin as UserAdmin.
Note:
See TracTickets
for help on using tickets.
I think
import UserAdmin as BaseUserAdmin
is an okay way to go. Any preferences?