Opened 7 years ago

Closed 7 years ago

#25793 closed Bug (duplicate)

Removing an MTI model generates an incorrect migration

Reported by: Ned Batchelder Owned by: nobody
Component: Migrations Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Ned Batchelder)

I had a model that inherited from two other models but added no fields of its own. When I removed the model and generated the migration, it was an invalid migration. It deleted each field individually, and then dropped the table. The problem is that you cannot drop the last field in a table, so the migration will not run.

A demonstration is at https://github.com/nedbat/django_issue_25793

Change History (2)

comment:1 Changed 7 years ago by Ned Batchelder

Description: modified (diff)

comment:2 Changed 7 years ago by Tim Graham

Resolution: duplicate
Status: newclosed
Type: UncategorizedBug

Looks like a duplicate of #24424.

Note: See TracTickets for help on using tickets.
Back to Top