Opened 4 years ago

Closed 4 years ago

#25601 closed Uncategorized (invalid)

makemigrations create unnecessary migrations

Reported by: Venelin Stoykov Owned by: nobody
Component: Migrations Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When verbose name of model or field is changed or some validator added/removed this creates unnecessary migrations. These attributes are not related to database at all and this will create extra migrations which then need to rebuild the state every time when migrations are run on validations are processed.

This is extra overhead that potentially can slow all tasks related to migrations, and also extra noise in version control and also is very annoying. This state (verbose name, validators and potentially other attributes) is not needed for datamigrations also.

I saw people to complain about speed of the new migrations framework and I think that this can help at least a little.

This is not tested it's jut my hypothesis.

Change History (1)

comment:1 Changed 4 years ago by Tim Graham

Resolution: invalid
Status: newclosed

This is by design, see #22837 and the last paragraph in The Commands section in the documentation.

Note: See TracTickets for help on using tickets.
Back to Top