Opened 4 years ago

Closed 4 years ago

#25523 closed Bug (duplicate)

manage.py runserver ignores logging configuration error and shows wrong exception

Reported by: Andriy Sokolovskiy Owned by: nobody
Component: Core (Management commands) Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

While trying to manage.py runserver, when LOGGING contains some error (e.g. log folder is missing, or version key is not included to logging configuration dict), runserver internals is catching actual exception and simply passing, and shows wrong error:

django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.

Here is a problem:

def setup():
    """
    Configure the settings (this happens as a side effect of accessing the
    first setting), configure logging and populate the app registry.
    """
    ...

    configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)  # <- exception from here is ignored
    apps.populate(settings.INSTALLED_APPS)  # <- this shows exception, but should show exception about logging

Tested on master and 1.8.
1.7 works as expected

Change History (2)

comment:1 Changed 4 years ago by Tim Graham

Might be a duplicate of #25510 -- could you test with that patch and if it doesn't work, bisect to the commit where the behavior changed?

comment:2 Changed 4 years ago by Andriy Sokolovskiy

Resolution: duplicate
Status: newclosed

Patch from #25510 works for me, closing as duplicate.

Note: See TracTickets for help on using tickets.
Back to Top