Opened 4 years ago

Closed 4 years ago

#25411 closed Bug (duplicate)

UnicodeEncodeError with ZIP of latest (pre 1.9) master and PIP and Python 2.7

Reported by: Carlton Gibson Owned by: nobody
Component: Packaging Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Setting a dependency on Django to the ZIP of the latest master results in an error with PIP and Python 2.7:

https://github.com/django/django/archive/master.zip

File ".../django-appconf/.tox/py27-dj19/lib/python2.7/site-packages/pip/utils/init.py",
line 231, in split_leading_dir

path = str(path)

UnicodeEncodeError: 'ascii' codec can't encode character u'\u2297' in position 60:
ordinal not in range(128)

Switching to the tar.gz resolves this.

There's a related PIP issue here: https://github.com/pypa/pip/issues/2729

Change History (2)

comment:1 Changed 4 years ago by Carlton Gibson

Version: master1.8

Working on this issue for https://github.com/django-compressor/django-appconf/pull/23, it seems to also apply to Django 1.8 — see build failure here: https://travis-ci.org/django-compressor/django-appconf/jobs/80584175

I hadn't noticed that.

comment:2 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #24408.

Note: See TracTickets for help on using tickets.
Back to Top