Opened 3 years ago

Closed 3 years ago

#25305 closed New feature (duplicate)

BIGINT auto field and related

Reported by: Bogdan Blidarescu Owned by:
Component: Database layer (models, ORM) Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hello,

It would be great if Django would support out of the box unsigned BIGINT (for MySQL) auto field for pk on models and also on related fields. Found a workaround that enables only pk and foreign key fields to be bigint, but not many to many field or other relations.
This is really breaking stuff, I am working with a legacy database and cannot change into normal int. The application is a large scale photo sharing app and this is very important to us.

Thank you

Change History (1)

comment:1 Changed 3 years ago by Tim Graham

Resolution: duplicate
Severity: Release blockerNormal
Status: newclosed

Duplicate of #14286

Note: See TracTickets for help on using tickets.
Back to Top