Opened 4 years ago

Closed 4 years ago

#25286 closed Bug (duplicate)

ImportError: cannot import name RemovedInDjango110Warning

Reported by: Forrest York Owned by: nobody
Component: Uncategorized Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Have an error in views.generic.edit where it can't import RemovedInDjango110Warning.

Traceback (most recent call last):
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/core/handlers/base.py", line 108, in get_response
    response = middleware_method(request)
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/middleware/common.py", line 74, in process_request
    if (not urlresolvers.is_valid_path(request.path_info, urlconf) and
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/core/urlresolvers.py", line 647, in is_valid_path
    resolve(path, urlconf)
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/core/urlresolvers.py", line 522, in resolve
    return get_resolver(urlconf).resolve(path)
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/core/urlresolvers.py", line 366, in resolve
    for pattern in self.url_patterns:
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/core/urlresolvers.py", line 402, in url_patterns
    patterns = getattr(self.urlconf_module, "urlpatterns", self.urlconf_module)
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/core/urlresolvers.py", line 396, in urlconf_module
    self._urlconf_module = import_module(self.urlconf_name)
  File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/home/ubuntu/fastrocs/dj_fastrocs/urls.py", line 20, in <module>
    url(r'^', include('fastrocs.urls', namespace='fastrocs')),
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/conf/urls/__init__.py", line 33, in include
    urlconf_module = import_module(urlconf_module)
  File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/home/ubuntu/django-fastrocs/fastrocs/urls.py", line 6, in <module>
    from . import views
  File "/home/ubuntu/django-fastrocs/fastrocs/views.py", line 6, in <module>
    from django.views.generic import View
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/views/generic/__init__.py", line 6, in <module>
    from django.views.generic.edit import FormView, CreateView, UpdateView, DeleteView
  File "/root/.virtualenvs/dj-fastrocs/local/lib/python2.7/site-packages/django/views/generic/edit.py", line 9, in <module>
    from django.utils.deprecation import RemovedInDjango110Warning

Change History (2)

comment:1 Changed 4 years ago by Tim Graham

Duplicate of #25101. Please reopen if you can provide steps to reproduce the issue.

comment:2 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top