Opened 9 years ago

Closed 8 years ago

#2526 closed defect (fixed)

manage.py sqlsequencereset doesn't work with empty tables.

Reported by: ben.tucker@… Owned by: adrian
Component: Core (Management commands) Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm using postgresql. If I delete the last item in a table and then pipe the output of manage.py sqlsequencereset to psql, it doesn't reset the sequence on empty tables. It should reset "is called" to No, and the last value to 1.

Change History (1)

comment:1 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

This must've been fixed a while ago, because I cannot reproduce it.

Note: See TracTickets for help on using tickets.
Back to Top