Opened 7 years ago

Closed 7 years ago

#25217 closed Cleanup/optimization (duplicate)

cleanup - M2M shouldn't take a 'default' kwarg

Reported by: mjlock Owned by: mjlock
Component: Core (Other) Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Many to Many field shouldn't take a 'default' kwarg as it doesn't use it. Should raise a warning if one is given.

Change History (3)

comment:1 Changed 7 years ago by mjlock

Owner: changed from nobody to mjlock
Status: newassigned

comment:2 Changed 7 years ago by mjlock

submitted pull request for this ticket: https://github.com/django/django/pull/5098

comment:3 Changed 7 years ago by Tim Graham

Resolution: duplicate
Status: assignedclosed

Duplicate of #2750. Adding a check as done here was tried there, but doesn't work.

Note: See TracTickets for help on using tickets.
Back to Top