Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#25059 closed Bug (fixed)

URLValidator does not pass some valid IDN top-level domans

Reported by: Alexey Sveshnikov Owned by: nobody
Component: Core (Other) Version: 1.8
Severity: Release blocker Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description (last modified by Alexey Sveshnikov)

There are some valid IDN top level domains with dashes which is not validated by URLValidator.

One example is '.xn--p1ai' which is punycode-encoded '.рф' (IDN TLD for Russian Federation)

This is a regression since 1.7.x

Pull request: https://github.com/django/django/pull/4949

Change History (7)

comment:1 Changed 5 years ago by Alexey Sveshnikov

Description: modified (diff)

comment:2 Changed 5 years ago by Tim Graham

Triage Stage: UnreviewedAccepted

comment:3 Changed 5 years ago by Tim Graham

Severity: NormalRelease blocker

comment:4 Changed 5 years ago by Baptiste Mispelon

For reference, the commit that introduced the regression is 2e65d56156b622e2393dee1af66e9c799a51924f.

comment:5 Changed 5 years ago by Tim Graham

Triage Stage: AcceptedReady for checkin

comment:6 Changed 5 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: newclosed

In bc98bc56:

Fixed #25059 -- Allowed Punycode TLDs in URLValidator

comment:7 Changed 5 years ago by Tim Graham <timograham@…>

In 8c417564:

[1.8.x] Fixed #25059 -- Allowed Punycode TLDs in URLValidator

Backport of bc98bc56a52860688ea0ae2ec7b9e59ddb72a811 from master

Note: See TracTickets for help on using tickets.
Back to Top