Opened 4 years ago

Closed 4 years ago

#25052 closed Bug (fixed)

UserCreationForm missing password_validaton.{validate,set}_password?

Reported by: Chris Lamb Owned by: nobody
Component: contrib.auth Version: master
Severity: Release blocker Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Using the new password validation framework, it looks like UserCreationForm is missing hooks to validate passwords as well as a trigger to set_password after successful creation of the user.

If this is deliberate, I think it would deserve an entry into docs; it's reasonable to assume that this form would validate passwords if there is a global setting for it.

Change History (3)

comment:1 Changed 4 years ago by Tim Graham

Severity: NormalRelease blocker
Triage Stage: UnreviewedAccepted
Version: 1.8master

No, it's not an intentional omission (confirmed on the django-developers thread).

comment:2 Changed 4 years ago by Tim Graham

Has patch: set

comment:3 Changed 4 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: newclosed

In 774c16d1:

Fixed #25052; refs #16860 -- Added password validation to UserCreationForm.

Note: See TracTickets for help on using tickets.
Back to Top