Opened 7 years ago

Closed 7 years ago

#24830 closed New feature (duplicate)

Add Support for Postgres' JSONB Type

Reported by: Alex Rothberg Owned by: nobody
Component: Uncategorized Version: dev
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

There are already a number of packages adding JSON field support for Django (https://www.djangopackages.com/grids/g/json-fields/) as well as some specific to Postgres' field (jsonb): https://github.com/yjmade/django-pgjsonb, https://github.com/djangonauts/django-pgjson and https://bitbucket.org/schinckel/django-postgres/overview.

One option is to add this field to django.contrib.postgres. Best would be if this field worked with SQLite and Postgres and used the native type in the case of Postgres.

Change History (1)

comment:1 Changed 7 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #12990 and #24604.

Note: See TracTickets for help on using tickets.
Back to Top