Opened 7 years ago

Closed 7 years ago

#24683 closed Bug (worksforme)

STATIC_ROOT needs to appear after INSTALLED_APPS

Reported by: SbSpider Owned by: nobody
Component: contrib.staticfiles Version: 1.7
Severity: Normal Keywords: documentation, staticfiles, static
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hi
I was working on a django website, and came across the following issue:

If the STATIC_ROOT defintion in settings.py towards the top of the file, it seems that
python manage.py collectstatic
will not be able to detect it. However, if it is declared after the INSTALLED_APPS, it works fine.

I am not sure whether this is intentional or not, but it does not seem to be documented, and therefore I believe should be brought to attention as either a documentation issue or a bug.

Change History (1)

comment:1 Changed 7 years ago by Marten Kenbeek

Resolution: worksforme
Status: newclosed

I am not able to reproduce this, on 1.7 or on master. Are you sure there is no error in your settings file, and that Django is using the correct settings file?

Note: See TracTickets for help on using tickets.
Back to Top