Opened 3 years ago

Closed 3 years ago

#24647 closed Bug (duplicate)

"django-admin compilemessages" does not compile translations for every app automatically, documentation is misleading

Reported by: jggc Owned by: nobody
Component: Documentation Version: 1.8
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The documentation at https://docs.djangoproject.com/en/1.8/topics/i18n/translation/ says

When you run makemessages from the root directory of your project, the extracted strings will be automatically distributed to the proper message files. That is, a string extracted from a file of an app containing a locale directory will go in a message file under that directory. A string extracted from a file of an app without any locale directory will either go in a message file under the directory listed first in LOCALE_PATHS or will generate an error if LOCALE_PATHS is empty.

And a bit further it says :

This tool runs over all available .po files and creates .mo files, which are binary files optimized for use by gettext. In the same directory from which you ran django-admin makemessages, run django-admin compilemessages like this:

This is misleading since django-admin compilemessages has to be ran in every application's directory.

Change History (1)

comment:1 Changed 3 years ago by Claude Paroz

Resolution: duplicate
Status: newclosed

Duplicate of #24159

Note: See TracTickets for help on using tickets.
Back to Top