Opened 9 years ago

Closed 9 years ago

#2463 closed defect (fixed)

[patch] "'ManyToManyRel' object has no attribute 'get_related_field'" error appears for all forms with M2M fields

Reported by: marcink@… Owned by: adrian
Component: Core (Other) Version: master
Severity: critical Keywords: patch
Cc: nesh@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The cause is change [3507], going back to [3506] makes the forms work again.

Attachments (1)

related.diff (1.0 KB) - added by nesh <nesh [at] studioquattro [dot] co [dot] yu> 9 years ago.
quick fix

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by nesh <nesh [at] studioquattro [dot] co [dot] yu>

quick fix

comment:1 Changed 9 years ago by nesh <nesh [at] studioquattro [dot] co [dot] yu>

  • Cc nesh@… added

This fix is worked for me. I'm tried to preserve changes from [3507] -- I'm not sure that this not break anything else.

comment:2 Changed 9 years ago by nesh <nesh [at] studioquattro [dot] co [dot] yu>

  • Keywords patch added
  • Summary changed from "'ManyToManyRel' object has no attribute 'get_related_field'" error appears for all forms with M2M fields to [patch] "'ManyToManyRel' object has no attribute 'get_related_field'" error appears for all forms with M2M fields
  • Version set to SVN

comment:3 Changed 9 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [3508]) Fixed #2463 -- Fixed temporarily broken many-to-many fields in admin interface due to [3507]. Thanks, Nesh

Note: See TracTickets for help on using tickets.
Back to Top