Code

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#246 closed defect (duplicate)

Can't do circular ForeignKey relationships between classes

Reported by: matt@… Owned by: adrian
Component: Metasystem Version:
Severity: minor Keywords: model circular foreign key
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Example case:

  • class Person belongs to a Company: ForeignKey(Company)
  • class Company designates a contact Person: ForeignKey(Person)

However, each class requires the other to be defined first. How does one implement this?

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #167.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.