Opened 9 years ago

Closed 9 years ago

#2459 closed defect (duplicate)

FilePathField limited to 100 chars

Reported by: lars.yencken@… Owned by: adrian
Component: Core (Other) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I've been using a FilePathField, but was wondering why I was suddenly getting bad truncation errors. Sure enough, FilePathField is limited in storage to 100 chars (at least on my mysql backend), even though the admin interface will list options which are longer than this (as it should).

You could argue that 100 chars should be enough for anyone, but I think that's a bit shortsighted, since you don't know what sort of deployment is going to be most convenient for your users. I'd request that you be allowed to optionally set a maxlength for FilePathField (defaulting to the current 100), rather than the current hard-coding. Alternatively, you could always just double or triple the hard-coded value, and most people would run into file system limits before hitting an error =)

Thanks!
Lars

Django version (0, 95, 'post-magic-removal')

Change History (1)

comment:1 Changed 9 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #231.

Note: See TracTickets for help on using tickets.
Back to Top