Opened 3 years ago

Closed 3 years ago

#24512 closed Bug (duplicate)

'ORA-01461: can bind a LONG value only for insert into a LONG column' error when loading data

Reported by: Primož Hadalin Owned by: nobody
Component: Database layer (models, ORM) Version: 1.7
Severity: Normal Keywords: oracle
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Primož Hadalin)

When using Oracle backend ORA-01461: can bind a LONG value only for insert into a LONG column is raised when loading data into TextField (NCLOB) with python manage.py loaddata

Test Django project and steps to reproduce are here https://github.com/hadalin/django-oracle-test

Attachments (1)

24512-test.diff (2.5 KB) - added by Tim Graham 3 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by Tim Graham

Any chance you could convert your test project into a test case for Django's test suite (tests/fixtures)?

comment:2 Changed 3 years ago by Primož Hadalin

Description: modified (diff)

comment:3 Changed 3 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

The query fails when the data for the TextField is longer than 2000 characters. Seems to be a duplicate of #20201 and #11487.

Changed 3 years ago by Tim Graham

Attachment: 24512-test.diff added
Note: See TracTickets for help on using tickets.
Back to Top