Code

Opened 8 years ago

Closed 7 years ago

#2444 closed defect (duplicate)

mange.py reset app fails, if initial sql data contains multiline fields with ; before eol

Reported by: r0nny Owned by: adrian
Component: Core (Management commands) Version: master
Severity: normal Keywords:
Cc: shaun@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

while creating my initial sql data i ran into this probem
i wanted to pass the content of a small c file, but it allways failed at the first ";" of the c-file

after it failed with django i tried manual executing, wich worked fine,
but every try with mange.py reset app failed, till i got rid of the ;

so i think its a small bug on the paser, cause it doesnt check parenthesis of single/double quotes and just splits on

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by shaun@…

  • Cc shaun@… added

I've submitted a patch to fix -- see ticket:3214

comment:2 Changed 7 years ago by Simon G. <dev@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Marked as duplicate of #3214

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.