Opened 4 years ago

Closed 4 years ago

#24283 closed Bug (duplicate)

ModelAdmin.media does not use get_prepopulated_fields

Reported by: Stratos Moros Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

While get_prepopulated_fields is used inside ModelAdmin, the media property accesses self.prepopulated_fields directly. The result is that urlify.js and prepopulate.js are not served to the client and the feature is essentially broken (since it works client side). The same applies to InlineModelAdmin

Change History (2)

comment:1 Changed 4 years ago by Tim Graham

Triage Stage: UnreviewedAccepted

comment:2 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #24467

Note: See TracTickets for help on using tickets.
Back to Top