Code

Opened 8 years ago

Closed 7 years ago

#2426 closed defect (duplicate)

validators.isValidANSIDate("2006-02-31",_) does not rise ValidationError

Reported by: m465@… Owned by: adrian
Component: Validators Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Built-in re-based validator does not catch invalid day-month combinations. Subsequent call to do_html2python force the value to None raising exception on the database level if the field is NOT NULL. Of cause one can add trivial custom validator for this check, but the better place is 'isValidANSIDate', because "2006-02-31" is really not a valid ANSI date.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Robert Myers <myer0052@…>

This appears to have been fixed in ticket #2674

comment:2 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

marking this a duplicate of #2674, since that ticket was already fixed :)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.