Code

Opened 8 years ago

Closed 8 years ago

#2405 closed defect (fixed)

[patch] django.contrib.auth.views.logout causes recursion error

Reported by: anonymous Owned by: adrian
Component: Contrib apps Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This is related to #2368 because that patch now catches the KeyError it is not passed to the view that was depending on it. So it looks like the view no longer needs the try catch.

The current state of Django is that when I try to logout I get recursive calls to logout.

[23/Jul/2006 13:40:11] "GET /accounts/logout/ HTTP/1.1" 302 0

[23/Jul/2006 13:40:11] "GET /accounts/logout/ HTTP/1.1" 302 0

[23/Jul/2006 13:40:11] "GET /accounts/logout/ HTTP/1.1" 302 0

[23/Jul/2006 13:40:11] "GET /accounts/logout/ HTTP/1.1" 302 0

[23/Jul/2006 13:40:11] "GET /accounts/logout/ HTTP/1.1" 302 0

Attachments (1)

logout.diff (738 bytes) - added by jay@… 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by jay@…

comment:1 Changed 8 years ago by jay@…

Oops, this was submited by me, not anonymous.

comment:2 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [3431]) Fixed #2405 -- Fixed recursion error in auth.views.logout(), caused by [3402]. Thanks, Jay Skabber

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.