Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#23969 closed Bug (fixed)

Test failures on Oracle -- ORA-01658: unable to [enlarge] tablespace

Reported by: Shai Berger Owned by: Shai Berger
Component: Testing framework Version: 1.7
Severity: Normal Keywords: oracle
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Consistently, in the last few runs on CI on all Python versions, and also reproduced on my machine:

======================================================================
ERROR [0.001s]: test_long_string (backends.tests.OracleTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "<http://djangoci.com/job/django-oracle-1.7/database=oracle11,python=python2.7/ws/tests/backends/tests.py",> line 81, in test_long_string
    cursor.execute('INSERT INTO ltext VALUES (%s)', [long_str])
  File "<http://djangoci.com/job/django-oracle-1.7/database=oracle11,python=python2.7/ws/django/db/backends/utils.py",> line 65, in execute
    return self.cursor.execute(sql, params)
  File "<http://djangoci.com/job/django-oracle-1.7/database=oracle11,python=python2.7/ws/django/db/utils.py",> line 94, in __exit__
    six.reraise(dj_exc_type, dj_exc_value, traceback)
  File "<http://djangoci.com/job/django-oracle-1.7/database=oracle11,python=python2.7/ws/django/db/backends/utils.py",> line 65, in execute
    return self.cursor.execute(sql, params)
  File "<http://djangoci.com/job/django-oracle-1.7/database=oracle11,python=python2.7/ws/django/db/backends/oracle/base.py",> line 916, in execute
    return self.cursor.execute(query, self._param_generator(params))
DatabaseError: ORA-01658: unable to create INITIAL extent for segment in tablespace D_DJANGOORACLE17_27

Notes:

  1. This is on 1.7.x only -- on master, this has been solved for good by the fix to #21775.
  2. This only shows up when running a lot of tests, although the failure is consistently in the same test.

Change History (5)

comment:1 Changed 6 years ago by Shai Berger <shai@…>

Resolution: fixed
Status: newclosed

In 991f523753baff73b32859c906649767a2bc8061:

[1.7.x] Fixed #23969: Made Oracle default test-tablespace larger.

It seems our test suite has grown...
Refs #21775

comment:2 Changed 6 years ago by Tim Graham

Shall we add a mention to the 1.7.2 release notes about this since it presumably also affects anyone who is running their own tests on Oracle?

Also the 1.8 release notes could be updated; it currently says "The default max size of the Oracle test tablespace has increased from 200M to 500M."

comment:3 Changed 6 years ago by Shai Berger

Yes, I thought it wasn't needed but you're right. I'll take care of it later (hopefully today).

comment:4 Changed 6 years ago by Shai Berger <shai@…>

In 9189ef438ef885446b20bf4c017d3cf53335ab08:

[1.7.x] Added release note for Refs #23969

comment:5 Changed 6 years ago by Shai Berger <shai@…>

In cc6275eeefe3da508a1203cf39aed237962e0171:

Ammended release notes for Refs #23969

(this includes a forward-port of 9189ef438ef885446b20bf4c017d3cf53335ab08)

Note: See TracTickets for help on using tickets.
Back to Top