Opened 9 years ago

Closed 8 years ago

#2395 closed defect (duplicate)

Failure to include required fields in Admin class results in non-obvious error

Reported by: ddipaolo@… Owned by: nobody
Component: contrib.admin Version: master
Severity: minor Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In contrib/admin/templates/admin/change_form.html , the "Please correct the error(s) below." message is displayed when form.error_dict is non-empty, but there are no errors actually displayed "below" if the fields that aren't validating are not included on the form because they aren't listed in the Admin class's fields attribute. As a result, the user is left looking for the aforementioned errors but won't find any. Either the message needs to be changed or some checking needs to be done to make sure that all required fields are included in the admin interface.

Change History (2)

comment:1 Changed 9 years ago by SmileyChris

  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 8 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #289.

Note: See TracTickets for help on using tickets.
Back to Top