Opened 9 years ago

Closed 9 years ago

#2393 closed defect (duplicate)

[patch] AttributeError in django/middleware/cache.py

Reported by: ludo@… Owned by: adrian
Component: Core (Other) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Changeset #3395 introduced a bug that raises the following exception

{{{Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/django/core/servers/basehttp.py", line 272, in run

self.result = application(self.environ, self.start_response)

File "/usr/lib/python2.4/site-packages/django/core/servers/basehttp.py", line 615, in call

return self.application(environ, start_response)

File "/usr/lib/python2.4/site-packages/django/core/handlers/wsgi.py", line 141, in call

self.load_middleware()

File "/usr/lib/python2.4/site-packages/django/core/handlers/base.py", line 38, in load_middleware

mw_instance = mw_class()

File "/usr/lib/python2.4/site-packages/django/middleware/cache.py", line 39, in init

self.cache_anonymous_only = settings.get('CACHE_MIDDLEWARE_ANONYMOUS_ONLY', False)

File "/usr/lib/python2.4/site-packages/django/conf/init.py", line 32, in getattr

return getattr(self._target, name)

AttributeError: 'Settings' object has no attribute 'get'
}}}

Attachments (1)

cache.diff (788 bytes) - added by ludo@… 9 years ago.
patch to django/middleware/cache.py

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by ludo@…

patch to django/middleware/cache.py

comment:1 Changed 9 years ago by ludo@…

  • Summary changed from AttributeError in django/middleware/cache.py to [patch] AttributeError in django/middleware/cache.py

comment:2 Changed 9 years ago by ludo@…

Changeset is [3395] ...

comment:3 Changed 9 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2392.

Note: See TracTickets for help on using tickets.
Back to Top