Opened 8 years ago

Closed 8 years ago

#23402 closed Cleanup/optimization (worksforme)

Minor incorrect links.

Reported by: michaeloconnor Owned by: nobody
Component: Documentation Version: 1.7
Severity: Normal Keywords: link
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

If you use the little Documentation Version widget in the lower right-hand corner of the Django docs to go to either the development version of Django x.x Release Notes or to 1.7, that takes you to a page with a URL of the form https://docs.djangoproject.com/en/xxx/releases/1.6/#new-test-runner, where xxx is either dev or 1.7 respectively.

The problem is the second version number in the URL. It should not be 1.6 but should be 1.7 if the widget selection is 1.7. But if you force it to dev when xxx is dev because you've selected development with the widget, that produces an error.

Change History (1)

comment:1 Changed 8 years ago by Baptiste Mispelon

Resolution: worksforme
Status: newclosed

Hi,

I'm not sure I understand the issue you're reporting and I can't reproduce any error.

The documentation switcher widget is not very smart: for every page of the documentation, it checks if that page is available in another version and if that's the case, a link to the same page for that version of Django is included.

The release notes are just a page like any others, there's no special casing for them.

Closing this as "worksforme". Please reopen if I've misunderstood your issue.

Thanks

Note: See TracTickets for help on using tickets.
Back to Top