Opened 9 years ago

Closed 9 years ago

#2329 closed enhancement (duplicate)

Allow password set on User's admin interface

Reported by: alang@… Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The password field that currently appears on the admin page for "User" is the field with the hashed value in it. It is difficult to set or reset a user's password with this page, because it requires generating the correct string in a Python interpreter shell and cutting and pasting it into the field. Overall, it is just simpler to use the raw User.set_password() function in a shell.

This request is for an additional "password" field on the admin interface. When a value is entered into this field, it is used to set the user's password. The old password field should then be renamed "password hash" and be hidden by default.

Change History (1)

comment:1 Changed 9 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #61.

Note: See TracTickets for help on using tickets.
Back to Top