Opened 2 years ago

Closed 11 months ago

Last modified 11 months ago

#23285 closed Bug (fixed)

Non-deterministic test: admin_views.tests.AdminViewBasicTest.test_change_list_sorting_model_admin_reverse

Reported by: Tim Graham Owned by: parasgithub
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Have seen this fail a couple times on Python 3:

Traceback (most recent call last):
  File "/home/jenkins/workspace/django-pull-requests/database/sqlite3/python/python3.4/tests/admin_views/tests.py", line 293, in test_change_list_sorting_model_admin_reverse
    "Results of sorting on ModelAdmin method are out of order.")
  File "/home/jenkins/workspace/django-pull-requests/database/sqlite3/python/python3.4/tests/admin_views/tests.py", line 93, in assertContentBefore
    failing_msg)
AssertionError: False is not true : Results of sorting on ModelAdmin method are out of order.

Change History (9)

comment:3 Changed 2 years ago by parasgithub

Owner: changed from nobody to parasgithub
Status: newassigned

comment:4 Changed 2 years ago by parasgithub

I can't reproduce this.

comment:5 Changed 2 years ago by parasgithub

Resolution: needsinfo
Status: assignedclosed

comment:6 Changed 2 years ago by Aymeric Augustin

Resolution: needsinfo
Status: closednew

There's evidence that it fails at least on the CI server.

comment:7 Changed 2 years ago by Tim Graham

Saw the failure on the CI server today on Python 2.

comment:8 Changed 11 months ago by Tim Graham

Resolution: duplicate
Status: newclosed

See #24316 comment 5 for the cause. I'll mark this as a duplicate of that ticket.

comment:9 Changed 11 months ago by Tim Graham

On second thought, since #24316 likely isn't a candidate for backport, how about a fix for the 1.8 and 1.9 branches because it's easy: PR.

comment:10 Changed 11 months ago by Tim Graham <timograham@…>

Resolution: duplicatefixed

In 2939ed4a:

[1.9.x] Fixed #23285 -- Fixed non-deterministic admin_views test.

This test sometimes fail because the checked integers can appear in the
output as memory addresses due to #24316.

comment:11 Changed 11 months ago by Tim Graham <timograham@…>

In 11601ee8:

[1.8.x] Fixed #23285 -- Fixed non-deterministic admin_views test.

This test sometimes fail because the checked integers can appear in the
output as memory addresses due to #24316.

Backport of 2939ed4a18864549a25807193ea5af490d632dc6 from stable/1.9.x

Note: See TracTickets for help on using tickets.
Back to Top