Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#23266 closed Bug (fixed)

Query relation lookup check issues extra queries.

Reported by: Florian Apolloner Owned by: Anubhav Joshi
Component: Database layer (models, ORM) Version: dev
Severity: Release blocker Keywords:
Cc: Tim Graham, ANUBHAV JOSHI Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The fix for #14334 issues extra queries when doing relational lookups with __in and a qs as argument. https://github.com/django/django/commit/34ba8670#diff-0edd853580d56db07e4020728d59e193R1100 should check if value is a qs and then check the modeltype or whatever. This release blocker is only for 1.8

Change History (3)

comment:1 Changed 7 years ago by Anubhav Joshi

Component: UncategorizedDatabase layer (models, ORM)
Has patch: set
Owner: changed from nobody to Anubhav Joshi
Status: newassigned
Triage Stage: UnreviewedAccepted

comment:2 Changed 7 years ago by Anssi Kääriäinen <akaariai@…>

Resolution: fixed
Status: assignedclosed

In cdfdcf4b70bebfc68871df885387790c6afbc23c:

Fixed #23266 -- Prevented queries caused by type checking lookup values

Small modifications done by committer.

comment:3 Changed 6 years ago by Tim Graham <timograham@…>

In 75b5de8d:

Refs #23266 -- Fixed ticket number reference in a queries test.

Note: See TracTickets for help on using tickets.
Back to Top